Problem/Symptom
You received a new Hub and tried to claim it via the ezeep admin portal, but you receive the error "Hub Unknown".
Cause
Hub firmware versions prior to 1.13 do not support Hub remote access or claiming. However, it is unlikely you would receive a Hub with a firmware version this old. If a Hub was updated to a recent firmware without a live internet connection, it may cause the Hub to not be registered in the cloud database.
Solution/Workaround
- Update the ezeep hub firmware. You will need to login to the ezeep hub console.
- Download the TPhubfinder.exe (attached below)
- Run and execute the TPHubfinder.exe on any windows pc
- The tool will automatically scan the network to find the ezeep hub
- Click on the IP address URL and this will open a web browser
- Enter the default password print4life
- You are now logged in to the ezeep hub console
- Download Firmware
- Make sure your Hub is connected to the internet (ensure it is plugged into a router or switch that has an active connection to the internet).
- Click on the "System" on the left pane
- Click on "Download Firmware"
- Wait for the installation finishes and the reboot.
- Try to claim the hub again.